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Welcome to Buy Now Pro Extension for Magento 2 developed by Sparsh

This extension allows us to have a "Buy Now" button to directly go to the checkout page to
speed up the checkout process and increase conversion rate on your Magento store. It will
make the checkout process easy and as quick as possible, especially for customers who
want to buy a particular product.

KEY FEATURES:

+» Easy to use
Make Checkout process easy
Multi-Lingual support

Create Buy Now button product wise

0’0

0’0

0’0

1. HOW TO CONFIGURE BUY NOW PRO EXTENSION

Go to [Magento 2 Admin] > Stores > Settings > Configuration > Sparsh Extensions >
Buy Now Pro

To Enable Extension:

Expand the General Configuration and choose “Show Buy Now Button™ as Yes.

Choose 'Yes' to enable extension. On disabling it "Buy Now"
- N Wi ! 3 G A 3|
GENERAL v General Configuration button won't be shown on frontend -
CATALOG v /
Show Buy Now Button | ...
SECURITY v
Advanced Configuration o)
CUSTOMERS ~
Add default button title td
SALES v Default Button Title | g\ o pro |/' show on frantend
This Title will be displayed in store front as Button Label.
SPARSH EXTENSIONS ~
Display a Sticky Bar Featuring Buy Now Yes
Button -
Banner Slider Advance o
Show Express Checkout Popup Yes
Buy Now Pro
Hide Add to Cart Button ...
Call for Pri
altorsnes Show on Catalog Page Yes

After enabling the extension, you will find the following configuration:

Buy Now Pro v1.0.0 https://lwww.sparsh-technologies.com



o Sparsh
Technologies

» Default Button Title: Enter the button title. This title will be displayed on the
storefront as label of Buy Now button when there is no specified button added for
particular product.

Display a Sticky Bar Featuring Buy Now Button I No - I o show Stl'd(‘,“ bar aon
product view page

Show Express Checkout Popup I Mo v

Hide Add to Cart Button |/ . v o show express chec
kout popup on click
Vs X of buy now button

Show on Catalog Page

Show on Product Detail Page || y..

You can choose to rest
Show on Search Res.L_lltTPa:g_e: Yes . \ rict the but now buttonj
to a specific page

Show on Related Products List || ..

Show on Up-5Sell Products List Yes

Show on Cross-Sell Products List

Yes
If you want to allow
Show on Wish LSt Page || ves . the product in custo
mer's cart to exist. then
fes Y choose 'Yes'. On choos

/ ing 'No' all products in
. I cart will be removed

Show on Compare Products Page List

Keep Products in Cart I Yes

On choosing 'No', all existing products in the cart will be removed.

» Display a Sticky Bar Featuring Buy Now Button : Choose “Yes” if you want to
show ““Sticky bar” on product view page.

» Show Express Checkout Popup: Choose “Yes” if you want to show product details
in popup on click of buy now button. This popup is visible when respective product
type is Configurable, Bundle and Grouped.

» Hide Add to Cart Button: Choose “Yes” if you do not want to show “Add to Cart”
button on the frontend.

» Show on Catalog Page: Choose “No” if you do not want to show the Buy Now
button on Catalog Page

» Show on Product detail Page: Choose “No” if you do not want to show the Buy
Now button on Product detail Page.

» Show on Search Result Page: Choose “No” if you do not want to show the Buy
Now button on Search result Page.

» Show on Related Products List: Choose “No” if you do not want to show the Buy
Now button on the Related products list Page.
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» Show on Up-Sell Products list: Choose “No” if you do not want to show the Buy
Now button on Up-Sell Products list Page.

» Show on Cross-Sell Products list: Choose “No” if you do not want to show the
Buy Now button on Cross-Sell Products list Page.

» Show on Wish List page: Choose “No” if you do not want to show the Buy Now
button on the wish list Page.

» Show on Compare Products Page list: Choose “No” if you do not want to show
the Buy Now button on the Compare Products page list

» Keep Products in cart: Choose “Yes” if you want to keep existing products in the
customer’s cart on click of Buy Now button. On choosing “No”, all the existing
products will be removed.

2. CONFIGURE BUY NOW BUTTON
Buy Now Pro extension allows users to Create Buy Now button product wise. User can
also customize button design.

Buy Now Buttons admin grid :
You can add new button on click of “Add New Button”

| Buy Now Button listing grid

Buy Now Button(s) Q M0 XL -
On Click on this
you can add New Button | ™ Add New Button
Search by keyword Q Y Filters ﬁ Columns X, Export v

Actions - 1 records found 20 ¥ | perpage 1 of 1

Buttton Text Buttton Font us Created At

1 Button Title Button Text Arial, sans-seri if Enabled 20 Apr 6, 2023 6:30:07 AM Edit

@ Copyright © 2023 Magento Commerce Inc. All rights reserved. Magento ver. 2.4.6

Privacy Policy | Report an Issue
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Add / Edit button :

User can customize buy now button . Via edit link given on button listing page.

Buy NOW Q ﬂ L admin -

| Here you can Add / Edit , Save and Delete button |

€ Back

I here you can add button details I

BUTTQN INFORMATION Details

Status *

Enable

I Delete Button I ISave and Continue Edit I

_______————P button design tab

Title * | Buy Now

| Assign Button to Products |
o

you can add button to desired
products

Button Text * Button Text

Sort Order * | 20

1. Details : In details tab , you can add basic button details.

BUTTON INFORMATION Details

- _ status of button
IButlonl\tIe I 4_‘we—l By N I

This text will be 'Eum_-lw- Button Text I

displayed on the
storefront as label of
button. sortorder *|| 20

You can add sort order of button
to sort the multiple button assign
ta same product

Main Website

Main website store

Default Store View

'You can restrict the display of
button to selected store view.

select customer Groups +f | ['nyoT LoGeED 1N

eneral You can restrict the display of
button to selected customer
groups

Wholesale

e Status : Select status of button.
e Title : Button title.
e Button Text : This text will be displayed on the storefront as label of button.

e Sort Order : You can add sort order of button to sort the multiple button
assign to same product.

e Store View : You can restrict the display of button to selected store view.
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e Select Customer Groups : You can restrict the display of button to selected
customer groups.

2. Designs : In designs tab , you can customize button designs.

BUTTON INFORMATION Designs
/ Font family of button text
Details
Select Font Family = | Arial . |
Designs ./
Button Radius * | 12px | ¥ Button border radius

Assign Button to Products

Button Background * . #0d272e Button background colo]
Button Color * #f3a358 Button text color

Additional Styles I padding:5px;margin:spx; |\

Additional styles
Please add in format “property:value;” for ex. “padding:Spx;margin:Spx;’ to add in button

e Font Family : Font family of button text

e Button Radius : Button border radius

e Button Background : Button background color.

e Button Color : Button text color

e Additional Styles : Additional styles to add in button.

3. Assign buttons to products

BUTTON INFORMATION Assign Button to Products

Search Reset Filter 2040 records found 20 | v | perpage 1 | of102 >

| | D 4| Thumbnail Name SKU Status

Assign Button to Products

D 1 & Joust Duffle Bag 24-MBO1 Enabled
Here, you can select products /

to assign button
2 ‘ Strive Shoulder Pack 24-MB04 Enabled

. Crown Summit Backpack 24-MB03 Enabled
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3. STOREFRONT VIEW
Clear cache from System > Tools > Cache Management if required.

Sticky Bar Featuring Buy Now Button
If “Display a Sticky Bar Featuring Buy Now Button” is set to “Yes” then sticky bar
will be visible on product detail page when page is scrolled down.

On click of “Buy Now Pro” button page scrolled up to the Add to Cart or Buy Now
Pro button.

b & 0. 3 Reviews Add Your Review

Montana Wind Jacket 3 A
onepainglace [ sticky bar featuring buy now button | €49
. =

US> 49,UU

Size
Xs s M L XL
Color

Qty

1

Buy Now Pro

@ ADD TO WISH LIST It ADD TO COMPARE
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Express checkout popup

Selection for shipping and payment option in popup and redirect to final payment page.
This is visible If “Show Express Checkout Popup” is set to “Yes” for Configurable,
Bundle and Grouped products.

Shopping Options 1 EH Items 1-12 of 14 SortBy | Position v | 4
STYLE v
SIZE v =

=
PRICE v i ’-ii‘

g T
" 5\
COLOR v ’
MATERIAL v
ECO COLLECTION v
PERFORMANCE FABRIC v : /
ERIN RECOMMENDS W Breathe-Easy Tank Antonia Racer Tank Maya Tunic Chloe Compete Tank
* %k 2 Reviews * %k 3 Reviews Yk ok o 1 Review 1 8. 8.8 3 Reviews
NEW v
As low as $34.00 As low as $34.00 As low as $29.00 As low as $39.00
SALE v
Xs s ™ L Xs s M L Xs s M L Xs s M L
PATTERN v
XL XL XL XL
CLIMATE v
Cofipare Produicts -q,,—>| Express checkout popup will open on click of button |
You have no items to compare. i ol . A n s

On click of “Buy Now Pro” button, it will open Express Checkout Popup

Breathe-Easy Tank

Breathe-Easy Tank

e e ek ok 2 Reviews Add Your Review
As low as e STOCK
SKU#: WT09
US$ 34,00
size
x W [ e
color
N
/ |

Buy Now Pro

/ \ W ADD TO WISH LIST  .l1 ADD TO COMPARE
{
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By default, the Buy Now button will be shown on Catalog Page, Product detail page,
Related products list page, Search result page, Up-sell products list page, Cross-sell
products list page, Wish list page and on Compare products page

— Catalog Page

Jacketg Buy Now Button on catalog page
Shopping Options s== o 12 Items SortBy | Position - |t
STYLE v
SIZE v f, -\ ;::,
PRICE ™. Q
COLOR V. ’
MATERIAL W
ECO COLLECTION b 4
PERFORMANCE FABRIC N W n
ERIN RECOMMENDS N Olivia 1/4 Zip Light Jacket Juno Jacket Neve Studio Dance Jacket Nadia Elements Shell
As low a5 USS 77,00 Yk Kk Y 3 Reviews % YKk 3 Reviews * %k k 3 Reviews
NEW v
As low a= USS 77,00 As Jow as USS 69,00 As low as USS 69,00
SALE v XS s Y]
L Xs S M L X5 s M L XS s M
PATTERN v
XL XL
CLIMATE v - - -
- I . I N . |
Compare Products
— Search Result Page
Home Search results for: watch
ol +|Buy Now Button on
Search results for: 'watch y
Search Result Page
pare Products HTE-H 9 ltems Sort By | Relevance v ¥
You have no items to compare.
-
=
y
ave no items u h list &;‘;.. " :
E. N .8 |
N ‘8
s Y
- '
'
n =
Dash Digital Watch Didi Sport Watch Luma Analog Watch Clamber Watch
'S & ] 3 Reviews * K%k 2 Reviews %%k Kk k2 Reviews * %4
US$ 92,00 US$ 92,00 Us$ 43,00 USS 54,00
BuyNowPro | | JN I
" m
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Home > Women > Tops > lackets > Olivia 1/4Zip Light Jacket

Buy Now Button on Product Detail Page

Olivia

/ /\\

1/4 Zip Light Jacket

Be the first to rev produc

As low as

uss$ 77,00

IN STOCK
SKU# W2

Size

\ Color

) mmEm
Qty

1

Buy Now Pro

Iy 20D TO cOMPARE

W ADD TO WISH LIST

— Related Products List Page

Related Products

Mimi All-Purpose Short
A5 low as USS 44,00
Buy Now Pro

v I

Buy Now Button on Related Products List Page

Gabriglle Micro Slesve
Top

Ana Running Short Juliana Short-Sieeve

ce
As low 2= USS 40,00

As low as USS 28,00 A5 low 2= USS 42,00

e
«
v I v I

Buy Now Pro v1.0.0
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— Up-sell Products List Page

We found other products you might like!

Buy Now Button on Up-sell Products List Page

W« W I

Fusion Backpack Wayfarer Messenger Rival Field Messenger Impulse Duffle Push It Messenger Bag Overnight Duffle
82

USs 59,00 vag USs 45,00 USs 74,00 Uss 45,00 USs 45,00
USs 45,00

o e S
Buy Now Pro

— Cross-sell Products List Page

Apply Discount Code ~

Summary
Bu\/ NOW Button on Estimate Shipping and Tax hd
More Choices: Cross-sell Products List Page - e
Discount -US% 99,40

Tax US$ 49,63

Order Total uss 787,23
4
Proceed to Checkout

Check Out with Multiple Addresses

Pursuit Lumaflex™ Tone Band ~ Go-Get'r Pushup Grips Sprite Foam Roller Quest Lumaflex™ Band

Uss 16,00 Uss 19,00 Uss 19,00 Uss 19,00

*k ok 2 Reviaws s de Ak 3 Reviews " Jd etk K 3 Reviews
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Com pa re Prod UCtS | Buy Now Button on Compare Products List Page

Print This Page

y

Montana Wind Jacket Jupiter All-Weather Trainer Fusion Backpack
b8 3 Reviews o9k 7o 3 Reviews Foddky 3 Reviews
As low as US$ 43,00 As low as US$ 56,99 Us$ 59,00

SKU Mjo3 MJ06 24-MBO2

Description Light-as-a-feather wind Inclement climate be With the Fusion Backpack

protection for runners, damned. With your strapped on, every trek is an

Joust Duffle Bag

%%

Buy NowPro R4

2 Reviews

24-MBO1

The sporty Joust Duffle Bag
can't be beat - not in the gym,

Wayfarer Messenger Bag
b .8.8.8

3 Reviews

Us$ 45,00

I -

24-MBO5

Perfect for class, work or the
gym, the Wayfarer

— Wish List Page

Buy Now Button on

sy i My Wish List
Wish List Page

Ny Orders

ly Dow

dable Products 5 item(s)

My Wish List

Address Book

My Product Reviews

Newsletter Subscriptions

Compare

X Montana Wind Jacket Mach Stre eatshirt Layla Tee
X Jupiter All-Weather Trainer USs 62,00 ok
X Fusion Backpack Comment Uss 56,99 USS 29,00
X Joust Duffle Bag £

- Qty

X Wayfar

ger Bag

X Proteus s Jackshirt

X Taurus Elements Shel
s @

Compare = Clear All

1

Neve Studio Dan

ok ko
USs 69,00

Buy Now Pro v1.0.0
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4. HOW TO SHOW IT ON DEFAULT WIDGET LIKE HOT SELLERS ON
HOMEPAGE

To have it on Hot Sellers section on homepage, go to Content > Elements > Blocks >
Edit Home Page Block

Click on “Show / Hide Editor” button and find the text as shown below

{{widget type="Magento\CatalogWidget\Block\Product\ProductsList"
products per page="8" products count="8"
template="product/widget/content/grid.phtml"

conditions encoded=""["1":"[ type : Magento| |CatalogWidget| |[Model |
|IRule| |Condition]| |Combine , "aggregator : all’, 'value : 1, new chi
1d :"""], "1--

1" :~[ type : Magento| |CatalogWidget| |Model| |Rule]| |Condition]| |Produ
ct’, "attribute : sku’, operator : (), value : WS1l2, WT09, MTQ7,
MHO7, 24-MB02, 24-WB04, 241-MB08, 240-LVO5 "]1"1"}}

Replace the highlighted text/template with below:

template="Sparsh BuyNowPro::catalog/product/widget/content/grid.ph
tml"

Save block and clear cache from System > Tools > Cache Management. Refresh
homepage and check Hot Sellers section.

Note: Take a backup of block content once, considering the risk of design getting broken if
you are not a technical person.
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Hot Sellers

Here is what"s trending on Luma right now

Radiant Tee Breathe-Easy Tank Argus All-Weather Tank
1.8 .8 ¢ 3 Reviews * kK7 2 Reviews As low as $22.00
As low as $22.00 As low 35 $34.00
XS S M
XS s L XS A L L
XL

L XS S M L

Buy Now Button on Homepage hot seller block

(=)

Hero Hoodie Fusion Backpack

As low as $54.00 * %k 3 Reviews

$59.00

5. MULTI-LINGUAL CONFIGURATION

Magento 2 by default provides language configuration. Navigate through Store >
Configuration > General > Locale Options to select your desired language from the
Locale option as required.

Configuration

GENERAL ~

General

Web

Currency Setup

Store Email Addresses
Contacts

Reports

Content Management

Country Options
State Options
Locale Options

Timezone
[website]
Locale

[store view]
Weight Unit
[store view]

First Day of Week
[store view]

Weekend Days
[store view]

Save Config

Change store

Central Standard Time (America/Chicago) v Language

7

English (United States) v

| Use system value

+| Use system value

~| Use system value

Buy Now Pro v1.0.0
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After changing the language, please navigate to vendor/sparsh/BuyNowPro/i18n/ if you
have installed extension using composer. Now, copy and paste the file en_US.csv in same
folder(i18n) and rename the file to selected region language and country code such as
(nl_NL.csv).

After creating the file, open the file and replace the word after comma(,) with your
translated word. Do the same for all the labels mentioned in the file.

After that please clear the cache from System > Tools > Cache Management and reload
page to reflect applied label changes in the backend module.
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