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Welcome to Call for Price for Magento 2 developed by Sparsh

This extension allows you to hide price and "Add to Cart" button and facilitates customers
to make inquiries about your products by filling in a simple popup form.

KEY FEATURES:

)
A X4

Enable the inquiry button to all products or separately per product.

Hide the price for all products or separately per product

Hide the "add to cart™ button for all products or separately per product.

Define the custom inquiry button text. E.g., "Click here for Inquiry™ or "Ask
Question™ or "Call for price".

Denies your competitors to disclose the price of your products.

Persuade customers to contact you for pricing.

Both customers & guest users can send the inquiry.

Add an inquiry form to any product.

Use ajax based inquiry form.

Notify admin via email.

Set your own email address and email template for inquiry.

Manage inquiry request details from admin.

By default, working on category listing page, product detail page, search result
page, advance search page, compare products page, related products, side bar, my
wishlist page etc...

Enable or disable as per convenience.

Free Support and Updates.
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1. HOW TO ONFIGURE CALL FOR PRICE EXENSION

To configure Call for Price extension, go to Magento Admin > Stores > Settings >
Configuration > Sparsh Extensions > Call for Price

 GENERAL SETTINGS

Here you can configure Call for Price extension, Admin can enable/disable “Add to Cart”,
Price and define the scope of it.

» Enable: Select “Yes” to enable Call for Price extension.
» Allow Add To Cart: Select “No” to hide add to cart button for all products.
» Disclose Product Price: Select “No” to hide prices for all products.

Call for Price v1.0.0 https://www.sparsh-technologies.com
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Configuration

SECURITY
CUSTOMERS
SALES

SPARSH EXTENSIONS

Product Inquiry

~ General Settings

Select “Yes” to enable Call for Price extension |

Save Config

=)
)

Select “No” to hide

v I/ add to cart button for

. \
e [
v
A\IowAdtﬁilzczrg | NoO
A~

all products

Disclose Prodlicl:(_fr\%ce | NoO

'|\

Category Specific

Call for Price Scope

Call for Price button wi

Call for Price
Select Categories
store vie Default Category
FAQ PRO
Gear
Training

how for selected scope.

= Select “No” to hide
prices for all products

» Call for Price Scope: Select Call for Price button scope. Select "Global™ to show
Call for Price on all products.

Select "Category Specific" to show Call for Price for selected category in General
Settings > Select Categories.

Select "Product Specific" to show Call for Price for selected product.

» Select Categories: Select categories to show Call for Price.

Call for Price Scope

Select Categories

| Category Specific v I\
Call for Price button will show for selected scope.

Select Call for Price
button scope

Default Category
Gear

Training

Men

Women

Sale

What's New

Call for Price button will show for selected Categories.

Select categories to

*lshow Call for Price

Call for Price v1.0.0
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Enable Call for Price As: Select whether to show Call for Price as "Button" or as
"Label".

When set as “Label”, label text shows as a label which does not have any form on
click of it.

Button Text: Enter the button text to be shown on a storefront. This will show
when “Enable Call for Price As” is set as “Button”

Enable Call for Price As select whether to show
fstore view | Button v |f Call for Price as "Button"
or as "Label"
ButtunhText | Call for price l\
Call for Price button will be replaced with the text added here, Enter the button text
to be shown on a storefront|

Label Text: Enter the label text to be shown on a storefront.
Label Text Color: Add label text color to show. This will show when “Enable Call
for Price As” is set as “Label”

Enable call for__F_’_rj_(e As | Label - | Enter the label text to

' he shown on a storefront
L_a;t:a:e_i'!'f.:}.t'; | Product Inquiry

Call for Price label will be replaced with the text added here.

Add label text color to
/ show

>

Enable Call for Price for Selected Groups: Select "Yes" to enable Call for Price
for specified customer groups.

Select Customer Groups: Select customer group to show Call for Price.

Show Inquiry Form In Product Information Tab: Select "Yes" to show Call for
Price form in product information tab on product view page.

Is the call for Price Tab not visible on frontend? Click here to show the tab

Inquiry Tab Label: Add tab label for Call for Price tab.

Call for Price v1.0.0 https://www.sparsh-technologies.com
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Enable Call for Price for Selected Groups

Yes

Select Customer Groups

Show Inquiry Form In Product
Information Tab

NOT LOGGED IN
General
Wholesale

Retailer

.|\

Call for Price will be shown for selected customer groups only.

| Yes

%] The inquiry button will display in preduct detail block.

Select "Yes" to enable
Call far Price for
specified customer

groups

Select customer group
to show Call for Price

Select "Yes" to show
Call for Price form in
product information
tab on product view
page

Add tab label for
Call for Price tab

Inquiry Tab Lat:el | title

|/

Note: To display Call for Price form to Tab in the Frontend

It needs to be pointed out that the functionality of the extension strongly depends on the
proper performance of the default Magento features. Magento removes the Product Tabs
block when the Layout is set to "*Product — Full Width** option in the products. In this case,
custom product tabs aren't added to the general Tabs block, as it does not exist in the "Full

Width" template.

In this case, to display Call for Price form Tab on the frontend, we recommend navigating to
Catalog > Products > Edit the product > Design and switch the Layout option to "*No

Layout Updates' value as mentioned in the screenshot below.

Crown Summit Backpack

FIUUULL 1T WELSILED

Product Salable Quantity @

Design

< Back Add Attribute m

Layout I No layout updates
[store view]

v |—— | Switch the Layout option

Custom Layout Update No update
[stare view]

Display Product Options In Block after Info Column | =

\Z/

©

@
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< ADMIN EMAIL SETTINGS

Call for Price extension will send email to admin when customer add Call for Price.

» Admin Email: Add the email address at which inquiry email will be received.

» Email Sender: Select email sender mail address.

» Email Template: Choose an email template for the inquiry email. You can define
your own template from Marketing > Email Templates and use it over here.

Admin Email Settings | Add the email address at which inquiry email will be received | )
i i f Select email sender
Admin Emf'! | sparsh.tester@gmail.com | ) ©
store viev / mail address
Email Sender - -
[store view] | General Contact = [ Choose an email templ
ate far the inquiry email
Email Ti@fla;e | v| Use system value

Email template chosen based on theme fallback when "Default
option is selected

% AUTO REPLY EMAIL SETTINGS

Call for Price extension will send auto reply email customer when customer add Call for
Price.

» Auto Reply Email to Customer: Select "Enable" to send auto reply email to
customer.

» Email Sender: Select the email sender from which auto reply email will be sent.

» Email Template: Select email template for auto reply email.

Auto Reply Email Settings | Select "Enable" to send auto reply email to customer | @

}

Auto Reply Email to Customer | Enable Select the email sender

| from which auto reply
" email will be sent.
Ema!\__‘s_indflf | General Contact v K

Email Template Select email template

| Call for Price Auto Reply (Default) v for auto reply email
E E
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% GOOGLE reCAPTCHA SETTINGS

Call for Price extension allows to enable the Google reCAPTCHA v3 in the Call for Price
form to avoid spam for Call for Price.

» Google reCAPTCHA: Select "Enable" to enable the Google reCAPTCHA in the
Call for Price form.

» Site Key: Enter the site key for Google reCAPTCHA v3.

» Secret key: Enter the secret key for Google reCAPTCHA v3.

Google reCAPTCHA Settings Select "Enable” to enable the Google reCAPTCHA o)
in the Call for Price form
Google reCAPTCHA | Enable - |f

Site Key | t_nter the s_|t<_= k(__w for.

store view | Google reCAPTCHA v3
Register with Google reCAPTCHA to get your site key.

Secret key | |/' Enter the secret key for

S Google reCAPTCHA v3

Register with Google reCAPTCHA to get your secret key.

s COUNT SETTINGS
Users can show the total Call for Price count on the product view page.

» Show Call for Price Inquiry Count: Select "Yes" to show Call for Price Inquiry
count on product view page.

» Inquiry Message For Already Inquired: Add message to show with Call for Price
count.

Count Settings | Select "Yes" to show Call for Price Inquiry count on product view pa_ﬁ,el

I

Yes ] |

®

Show Call for Price Inquiry Count

) . Add message to show
Inquiry Message For Already \nq:ured | Customer(s) had already inquired for this product. V with Call for Price count

This message will display in front side.
Ex. {count} customer(s) had already inquired for this product.

Call for Price v1.0.0 https://www.sparsh-technologies.com



o Sparsh

Technologies

2. LIST CALL FOR PRICE INQUIRIES

To check or delete Call for Price inquiries go to Magento Admin > Call for Price

| On this grid, You can check all call for price inquiries |

Call For Price Inquiries Q M0 L~
Search by keyword Q Y Filters Q- Columns + L Export w
Actions ‘ a 1 records found 20 > | perpage 1 af 1

Delete

Description Inquiry Date

Veronica Costell 1234567778 roni_cost@example.com MTO7 cost of this product ? May 5, 2023 1:25:02 AM

You can also delete the inguiries you no longer needed

3. CALL FOR PRICE FOR SPECIFIC PRODUCT

Admin can add Call for Price for specific product, this will show when Store >
Configuration > Call For Price > General Settings > Call for Price Scope configuration
Is set to ""Product Specific".

To configure Call for Price for a specific product, navigate to Catalog > Products > Edit
product > Call For Price and edit according to requirement.

» Enable: Select ""Yes" to show Call for Price for respective product.

» Label: Call for Price label/button text.

» Allow Add to Cart: Select “No” to hide add to cart button for product.
» Disclose Product Price: Select “No” to hide prices of product.

Call for Price

®

| Select "Yes" to show Call for Price for respective productl

Igloba Call for Price label/button
T text

Label | Call for Price |
[globa

Leave label as blank if you just want to hide price without having any inquiry button

Allow Add To Cart | Select “No” to hide add to cart button for productl
Igloel
Disclose Product Price Select “No” to hide prices of product
[glopal

Call for Price v1.0.0 https://www.sparsh-technologies.com
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4. DATA MIGRATION
We provide functionality that allows you to migrate from the Product Inquiry With Hide
Price Extension to the Call for Price Extension in one click.

Users with Product Inquiry With Hide Price Extension installed only see the Migrate
button.

Migrate Extension from Store > Configuration > Sparsh Extension > Call for Price

We have detected Sparsh Product Inquiry With Hide Price module in your project. If you want to migrate
data to Sparsh Call for Price module, please click on Migrate button. Migrate

General Settings Click here to migrate data

@

No

.......

Disclose Prod;::c.:(_frlég_e Mo

5. STORE FRONT VIEW
Clear cache from System > Tools > Cache Management if required. By Default, it will be

shown on Category listing page, Product detail page, Search result page, Advance search
page, Compare products page and My wish list page.

This extension allows you to show Call for price as button or as a label.
1.Label

When Store > Configuration > Sparsh Extension > Call for Price > General Settings >
Enable Call for Price As set as “Label”

1. Call for price Label will be shown as mentioned in Screenshot below when Store >
Settings > Configuration > Sparsh Extensions > Call For Price > General
Settings > Show Inquiry Form in Product Information Tab configuration is set
to “No”.

Call for Price v1.0.0 https://www.sparsh-technologies.com
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What's New Women v Men v Gear v Training v Sale

ler Pack Call for Price label on Product Detail Page |

Strive Shoulder Pack

Sde Aok 2 Reviews  Add Your Review
IN STOCK
SKU#: 24-MB04
Contact Us for Product Inquiry
@ ADD TO WISH LIST «l1 ADD TO COMPARE

2. Call for price label will be shown as mentioned in Screenshot below when
Settings > Configuration > Sparsh Extensions > Call For Price > General

Settings > Show Inquiry Form in Product Information Tab configuration is set

to “Yes”.

I Call For Price Tab mxtl

| Call for price at 89653253200

OTE TITOT TGO

Reviews ()

| Contact Us for Product Inquiry

Call for Price v1.0.0
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2.Button

When Store > Configuration > Sparsh Extension > Call for Price > General Settings >
Enable Call for Price As set as “Button™. Belows are screenshot when set as Button

» Product Detail Page
There are two ways to show Call for price inquiry form

1. Call for price button will be shown as mentioned in Screenshot below when Store
> Settings > Configuration > Sparsh Extensions > Call For Price > General
Settings > Show Inquiry Form in Product Information Tab configuration is set

to “NO”

I Call for price button on Product Detail Page |

Argus All-Weather Tank

)

]

e
y inquired for this produ
x.h ADD TO COMPARE

color

call for pric
1 Customer(s) had alread;
‘W ADD TO WISH LIST

| Call for price inquiry count |

Call for Price v1.0.0 https://www.sparsh-technologies.com
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2. Call for price form will be shown as mentioned in Screenshot below when
Settings > Configuration > Sparsh Extensions > Call For Price > General
Settings > Show Inquiry Form in Product Information Tab configuration is set
to “Yes”.

call for price Product Questions Details More Information Reviews

Call for price form in product information tab

call for price
1 Custameniz] had already inquired for this product. Call for price inquiry counts with message
HNam:
shone
Phone
Email *
Emai
Descripti
Descriptic

» Category Listing Page

Tops
shopping Options t
CATEGORY »
SIZE v
PRICE v
COLOR v
MATERIAL *
ECO COLLECTION v
ERIN RECOMMENDS »
NEW v
SALE k-4
PATTERN »
CLIMATE v
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» Compare Products Page

Compare prOd ucts I Call for price button Compare Products Page

Print This Page
x
Hero Hoodie Abominable Hoodie
v v
call for price
KU MHO7 MHD
Description

- Full-sip gray and black hoadie.
-Ribbed hem.

- Standard fit.

+ Drawcord hood dnch.

- Water-resistant coating,

» Search Result Page

Home Search results for: hoadie

Search results for: 'hoodies'

| 53| remst120f21 I Call for price button on Search Result Page SortBy | Relevance v | ¥

Did you mean

hoodie

h List hood

Abominable Hoodie Hera Hoodie Chaz Kangeroo Hoodie
SRS E x| s [ m || n xs | sl |
= = s | . L =
X
I . . BB |
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» My Wish List Page

My Wish List

Call for Price button My Wish List Page

My Downloadable Products 8 Item(s) Show | 10 v | per page

My Wish List

Stellar Solar Jacket

Jek Kk 3 Reviews

Savvy Shoulder Tote Endeavor Daytrip Backpack Miko Pullove

Jekkk ok 2 Reviews Kkok A K 3 Revews

Comment

6. CALL FOR PRICE FORM POPUP

On click of an inquiry button, a popup form will be opened to inquire about given product.

Call for price popup form |
Hero Hoodie

Name *
sparsh tester
Phone
4567895230
Email *

test@gmail.com

how much it cost?

Customer can ask doubts regarding given product |

Call for Price v1.0.0 https://www.sparsh-technologies.com
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7. CALL FOR PRICE INQUIRIES IN CUSTOMER’S MY ACCOUNT SECTION

Customers can check all Call For Price Inquiries asked by him/her in the *"Call For Price
Inquiries™ tab in customer my account page.

My Account Ca” For Pr"ce ‘nquirv‘es
My Orders

My Downloadable Products Description Product Image Product Inquiry Requested on Action

My Wish List

cost of this product ? 3 Argus All-Weather Tank 2023-05-05 06:25:02
Address Book
Account Information View Inquiry

Stored Payment Methods

My Product Reviews 1 ltem Show | 5 w | perpage

Newsletter Subscriptions | Customer can check all call for price inquiries inquired by them |

|| call For Price Inquiries

My Questions And Answers

8. HOW TO SHOW IT ON DEFAULT WIDGET LIKE HOT SELLERS ON
HOMEPAGE

To have it on Hot Sellers section on homepage, go to Content > Elements > Blocks >
Edit Home Page Block

Click on “Show / Hide Editor” button and find the text as shown below

{{widget type="Magento\CatalogWidget\Block\Product\ProductsList"
products per page="8" products count="8"
template="product/widget/content/grid.phtml"

conditions encoded=""["1":"[ type : Magento| |CatalogWidget]| Model|
|IRule| |Condition]| |Combine , "aggregator : all’, 'value : 1°, new chi
1d : A, “1--

1" :~[ type : Magento| |CatalogWidget| |Model||Rule]| |Condition| |Produ
ct’, "attribute : sku’, operator : (), value : WS1l2, WT09, MTQ7,
MHO7, 24-MB02, 24-WB04, 241-MB08, 240-LV05 "~]1"]1"1}}

Replace the highlighted text/template with below:

template="Sparsh ProductInquiryPro::product/widget/content/grid.ph
tml"

Save block and clear cache from System > Tools > Cache Management. Refresh
homepage and check Hot Sellers section.

Note: Take a backup of block content once, considering the risk of design getting broken if
you are not a technical person.
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