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Welcome to Product Inquiry with Hide Price Extension for Magento 2 developed by
Sparsh.

We have provided this guide to understand better use of this extension.

This extension allows you to hide price and "Add To Cart" button and facilitates
customers to make inquiries about your products by filling a simple popup form.

KEY FEATURES:

« Enable the inquiry button to all products or separately per product.

++ Hide the price for all products or separately per product.

+« Hide the "add to cart" button for all products or separately per product.

+« Define the custom inquiry button text. E.g., "Click here for Inquiry" or "Ask
Question™ or "Call for price".

+«+ Denies your competitors to disclose the price of your products.

+ Persuade customers to contact you for pricing.

% Both customers & guest users can send the inquiry.

% Add inquiry form to any product.

% Use ajax based inquiry form.

+« Notify admin via email.

% Set own email address and email template for inquiry.

« Manage inquiry request details from admin.

+« By Default working on category listing page, product detail page, search result
page, advance search page, compare products page, related products, side bar, my
wishlist page etc...

% Enable or disable as per convenience.

K/
%

Free Support and Updates.
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Follow given below steps from admin dashboard:

1. HOW TO ENABLE INQUIRY, HIDE PRICE AND/OR HIDE ADD TO CART
BUTTON FOR ALL PRODUCTS

Go to Magento 2 Admin > Login > Stores > Configuration > Sparsh Extensions >
Product Inquiry.

General Settings ®

Enable ’ Ves = ’
[store view]
Enter button label for

Product inquiry / Call for [ __Label \click here for Inquiry ‘

[store view]

o Leave label as blank if you just want to hide price without having any
inquiry button.
Choose "No" to hide
G Adg;(f)es':-rftl ’ i ‘ v ’ ~add to cart button
for all products.
Choose "No" to | |Disclose Product Price \ No F’
hide price for all [store view]

products. Leave .
label as blank if [T&ET:;: \ General Contact
you just want to

hide prices . =

Witho?]t having Email 1[’::’::5\!?655] Product Inquire Form (Default) - [v] Use system value
to add inquiry Email template chosen based on theme fallbackjwhen "Default™ option

button. is selected.

You can define own template from Marketing > Email
Templates and use it over here.

Expand the General Settings section, and do the following:

> Enable: Select “Yes” to enable for all products of given store view.

> Label: Enter the inquiry button label to be shown on a storefront. Leave label as
blank if you just want to hide price without having any inquiry button.

> Allow Add To Cart: Select “No” to hide add to cart button for all products.

> Disclose Product Price: Select “No” to hide price for all products.

> To Email: Select email address on which inquiry email will be received.
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> Email Template: Choose an email template for the inquiry email. You can define
own template from Marketing > Email Templates and use it over here.

2. HOW TO ENABLE INQUIRY, HIDE PRICE AND HIDE ADD TO CART
BUTTON FOR A SPECIFIC PRODUCT
Go to [Magento 2 Admin] > Login > Catalog > Inventory > Products

Choose the “edit” option in the select dropdown of action column for a particular
product.

Active filters:  Enable: Yes €3 Clear all
Search by keyword Q
Actions 2 records found You can edit any specific product to which you want to = per page < \ 1 | of1

add the "Product Inquiry". I | J

Attribute Salable 8
1
W3 o Thumbnail | Name g Price | Quantity Quantity Visibility Status Websl(e ahirad Cost | Action Enable

1738 Nona Fitness ~ Configurable 0.0000 Catalog, Enabled = Main No Yes
[ Tank Product Search Website
i
1818 9 Breathe- Configurable Top WT09 0.0000 Catalog, Enabled = Main Yes Edit Yes
J Y Easy Tank Product Search Website

Find the “Product Inquiry” section as shown in below screenshot, and do the following:

> Enable: Select “Yes” to enable for a given product only.

> Label: Enter the inquiry button label to be shown on a storefront. Leave label as
blank if you just want to hide price without having any inquiry button.

> Allow Add To Cart: Select “No” to hide add to cart button for a given product.
> Disclose Product Price: Select “No” to hide price for a given product.

Product Ingquiry: ¢ | Product Inquiry for an individual product. |

Enable (7 ) Yes
[global]

Label ‘ Click here for Inquiry |
global]

Leave label as blank if you just want to hide price without having any inquiry button. l

Allow Add To Cart ) No |\> Set options for hiding price, hiding Add to Cart button
Lkl Or Product inquiry / Call for price for an individual product.

Disclose Product Price () No /
[giobal]
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3. STORE FRONT VIEW
Clear cache from System > Tools > Cache Management if required.

By Default, It will be shown on Category listing page, Product detail page, Search result
page, Advance search page, Compare products page and My wish list page.

->» Category Listing Page

Home > Women > Tops > Jackets

_Ja ¢ ketS Product Inquiry on category page.

Shopping Options A Items 1-9 of 12 Sort By = Position v |4
STYLE v

SIZE v

CLIMATE v )

’
COLOR v
ECO COLLECTION v

ERIN RECOMMENDS v

MATERIAL V. Olivia 1/4 Zip Light jacket Juno Jacket Neve Studio Dance Jacket Nadia Elements Shell
NEW v XS s M ek kv 3 reviews ok KK 3 reviews 1. 8.8 ¢ 3 reviews
Xs s M XS s M XS s M
PATTERN v =
L XL L XL L XL
PERFORMANCE FABR v - - -
ic ¢ . [ B B HE I

v
i Click here for Inquiry
SALE T _ ‘ & ! )
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-> Product Detail Page

What's New Women v Men v  Gear v

Training v Sale

Product Inquiry on detail page. |

Home > Breathe-Easy Tank

Breathe-Easy Tank

b 2. 8. 85 2 Reviews  Add Your Review
IN STOCK
SKU#: WT09
Size
XS s M L XL
Color
Call for price
& ADD TO WISH LIST .l1 ADD TO COMPARE 4 EMAIL

- Compare Products Page

What'sNew  Women v Men v Gear v

Compare Products

Print This Page

Desiree Fitness Tee

ek

3 Reviews

Click here for Inquiry

SKU WS05

When you're too far to rn
back, thank yourself for
choosing the Desiree Fitness
Tee. Its ultra-lightweight,
ultra-breathable fabric wicks
sweat away from your body
and helps keeps you cool for
the distance.

Description

Training v Sale

Product Inquiry on compare products page.

Ql. C '

Olivia 174 Zip Light Jacket

Click here for Inquiry

w12

Running errands or headed
to the gym, you just want to
be comfortable. The Olivia
Light Jacket promises that,
plus a laid-back look. This zip-
up is designed with shoulder
stripes for an athletic touch,
and banded waist and

Sprite Yoga Companion Kit

Click here for Inquiry

24-WG080

Awell-rounded yoga workout
takes more than a mat. The
Sprite Yoga Companion Kit
helps stock your studio with
the basics you need for a full-
range workout. The kit is
composed of four best-
selling Luma Sprite

Set of Sprite Yoga Straps

Click here for Inquiry

24-WG085_Group

Great set of Sprite Yoga
Straps for every stretch and
hold you need. There are
three straps in this set: 6, 8'
and 10

* 100% soft and durable
cotton.

Luma Yoga For Life

Click here for Inquiry

240-Lv0o9

* Increase strength +
flexibility + metabolisn

« Burn calories + feel
great
* Gain energy +

youthfulness + mental
wellness
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-> Search Result Page

Search results for: 'radiant'

Product Inquiry on search results page.

Compare Products i EE 1item

You have no items to

compare. Related search terms
radiant tee

My Wish List

You have no items in your
wish list.

Radiant Tee
¥ % K i 3 reviews
XS 3 M
L XL
¥ .Ih

| Click here for Inquiry |
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What's New Women v

My Account
My Orders

My Downloadable
Products

My Wish List

Address Book
Account Information
Stored Payment Methods

Billing Agreements

My Product Reviews
Newsletter Subscriptions

PayPal Recurring
Payments

Compare Products (7 items)

Desiree Fitness Tee

Olivia 1/4 Zip Light Jacket
Sprite Yoga Companion Kit
Set of Sprite Yoga Straps

Luma Yoga For Life

X X X X X X

Proteus Fitness Jackshirt

Men v

Gear v  Training v

My Wish List

4 Item(s)

Sale

Product Inquiry on my wishlist page.

Show

10 v | per page

Overnight Duffle avvy Shoulder Tote Miko Pullover Hoodie Stellar Solar Jacket
* * * 3 reviews k*** 2 reviews *** 3 reviews ***‘, 3 reviews
See Details See Details
Comment
Qty Ee Wish List Add All to Cart
7
Show | 10 v | per page

Click here for Inquiry

7
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4. PRODUCT INQUIRY

On click of an inquiry button, a popup form will be opened to inquiry about given

product.

Product inquiry popup form. Admin will receive an email

Desiree Fitness Tee on submission of the form.

Name *

Veronica Costello

Phone

Phone
Email *
roni_cost@example.com
Description *

Description

Customer can ask doubts regarding given product.

On submission of the form, an email will be sent to admin on email address set on
configuration page and an entry will be listed on Admin => “Product inquiry” grid page

as well.

Product Inquiries

On this grid, you can manage all your inquiries.J

Actions | a 2 records found

20 v | per page

product?

3 Rahul +1%325897745  rahul@example.com

product?

You can also delete the inquiries you no longer need.

Delete
e Nane I’hone Email SKU Description Inquiry Date

A = +14325897745 = roni_cost@example.com = WJ12 = Hi..l am interested in your product so can you tell me the availability and the cost of the

WJ12  Hi..l am interested in your product so can you tell me the availability and the cost of the

Q _‘ X admin v

< ‘j of1 | >

Sep 12,2019 12:41:43
PM

Sep 12,2019 12:42:51
PM
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5. HOW TO SHOW IT ON DEFAULT WIDGET LIKE HOT SELLERS ON
HOMEPAGE

In order to have it on Hot Sellers section on homepage, go to [Magento 2 Admin] >
Login > Content > Elements > Blocks > Edit Home Page Block

Click on “Show / Hide Editor” button and find the text as shown below.
<p>{{widget type="Magento\CatalogWidget\Block\Product\ProductsList"

products per page="8" products count="8"
template="product/widget/content/grid.phtml"

conditions _encoded=""["1":"[ type : Magento||CatalogWidget| |Model| |Rule]| |Cond
ition| |Combine’, "aggregator : all’, "value : 1", 'new child : "], "1--

1" :~[ type : Magento]| |CatalogWidget| |Model| |Rule| |Condition]| |Product”, "attrib
ute’: sku’, “operator : (), value : WS1l2, WT09, MTO7, MHO7, 24-MB02, 24-WB04,
241-MB08, 240-LV05 ~]1~]1"}}</p>

Replace the highlighted text/template with below:
template="Sparsh ProductInquiry::product/widget/content/grid.phtml"
Save block and clear cache from System > Tools > Cache Management.

Refresh homepage and check Hot Sellers section.

Product Inquiry on default widget like }ﬁOtSeHerS

Hot Sellers on Homepage.

Here is what s trending on Luma right now

2 o

|FELONG O v
FITNESS

Vs
@ [
— —

Breathe-Easy Tank Radiant Tee Argus All-Weather Tank Hero Hoodie LifeLong Fitness IV
Fookok 2 reviews o kok 3 reviews XS . = 5 v . ; :

XS s M L XS s ] L XL "

- _ |-7 .-
- - - - Click here for Inquiry

¥ .I
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Note: Take a backup of block content once, considering the risk of design got broken in
case you are not a technical person.

To get an email, below basic settings needs to be done from admin.

6. ENABLE EMAIL CONFIGURATION

Go to Magento 2 Admin > Login > Stores > Configuration > Advanced > System > Mail
Sending Settings

You can also install any third party extension for SMTP email.

You can find more details on https://docs.magento.com/m2/ce/user guide/system/email-
communications.html

Mail Sending Settings

Disable Email Ccmmur[\_l_cﬂe‘l:t!“oﬂs? v| Use system value

HGSI ocalhost v| Use system value

[sto
For Windows server only.

[Port (25) 25 +| Use system value

For Windows server only.

Set Re‘“”‘,j_"f:’:tﬁ No

6.1. SET FROM EMAIL ADDRESS
Go to Magento 2 Admin > Login > Stores > Configuration > General > Store Email
Addresses > General Contact

By default, general contact name and email is used as from name and from email address.

General Contact
Use system value

Sender Name -
[store view]

+| Use system value

Sender Email
[store view]
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