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Welcome to Product Questions & FAQ Extension for Magento 2 developed by Sparsh 

 
This extension allows us to add product questions tab which allows users and admin to ask 

and write questions about products that helps visitors to understand products features 

better.  

 
This extension can assist customers to find the common inquiries on the knowledge base 

and FAQ lists. The module allows the admin to add questions and answers and list them on 

the front end with Tabs / Categories. 

 

KEY FEATURES: 

 Allows customers and admin to ask and add questions about product 

 Registered customer can track questions they asked 

 Admin can track answers activities 

 User can report an abusive answer 

 Admin and Customer can receive email notification 

 FAQ Categories are shown in sidebar 

 Custom title for FAQ block 

 Group and Filter FAQ by categories. 

 Disable the extension when not in use 

1. HOW TO CONFIGURE PRODUCT QUESTION EXTENSION 

    To configure Product Questions extension, go to Magento Admin > Stores > Settings > 

Configuration > Sparsh Extensions > Product Questions 

To Enable Extension:  

Expand the Configuration and choose “Product Questions” as Enable. 

 Configuration 

Admin can add basic configuration in the configuration tab. 

 Product Questions: Choose Enable to add product Questions tab. 

 Product Page Tab Title: Add the title for the product questions tab on the product 

page. 
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 Question Settings 

    Configure product questions and product questions form. 

 Enable Search Question: Select "Yes" to show the search field for product 

questions. 

 Show Ask a Question Form: Select "Yes" to show product question form to user. 

 Allow Guests to Write Questions: Select "Yes" to allow guest user to ask 

questions. 

 Auto Approve New Question: Select "Yes" to auto approve the new question. 

 Show Nickname Field: Select "Yes" to show the nickname field in question form. 

 Nickname Required: Select "Yes" to make nickname field as required field. 

 Show Email Field: Select "Yes" to show the email field in the question form. 

 Email Required: Select "Yes" to make email field as required field. 
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 Answer Settings 

    Configure product questions answer, product questions answer form and answer like and 

dislike activities. 

 Show an Answer Form: Select "Yes" to show question answer form to user. 

 Allow Guests to Write Answer: Select "Yes" to allow guest user to answer the 

question. 

 Auto Approve New Answer: Select "Yes" to auto approve the new added answer. 

 Show Nickname Field: Select "Yes" to show the nickname field in answer form. 

 Nickname Required: Select "Yes" to make nickname field as required field. 

 Show Email Field: Select "Yes" to show the email field in answer form. 

 Email Required: Select "Yes" to make email field as required field. 

 Show Certified Buyer Label: Select "Yes" to show certified buyer label below an 

answer. 

 Enable Like: Select "Yes" to show like field to allows user to like an answer. 

 Enable Dislike: Select "Yes" to show dislike field to allows user to dislike an 

answer.
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 Report Abuse Answer Settings 

    Report answer as abuse activity can be configured from here. 

 Enabled: Select "Enable" to allow users to report an inappropriate or abusive 

answer. 

 Send Emails To: Add email Address. Email sends to this email id when user report 

an answer. 

 Email Sender: Select email sender. 

 Email template: Select email template.
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 Question Email Notification Settings 

    Admin gets email notification when customers add product question. Configure email 

notification here. 

 Enabled: Select "Enable" to send email to admin when a new question is submitted 

by user. 

 Send Emails To: Add email address. Email is sent to this email address. 

 Email Sender: Select email sender. 

 Email template: Select email template. 

       

 Answer Email Notification Settings  

Admin and questioner get notification when customer answers their questions. Admin can 

configure email notifications from here. 

 Send Answer Email Notification to Customer: Select "Yes" to allow to send 

email notification to customer when someone post answer for their question. 

 Customer Email Sender: Select email Address of sender for customer email 

notification. 

 Customer Email Template: Select email template for customer email notification. 

 Send Answer Email Notification to Admin: Select "Yes" to allow to send email 

notification to admin when someone posts answer for question. 

 Send Email To: Add email Address. Email notification is sent to this email address. 

 Admin Email Sender: Select email sender for admin email notification. 

 Admin Email template: Select email template for admin email notification. 
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2. MANAGE PRODUCT QUESTIONS 

   To manage product question, go to Magento Admin > Market > Manage Product Questions. 

Here you find all product questions in grid. To approve or change the status of question and 

any question detail click the "Edit" link for respective question. Admin can delete single or 

multiple questions using the delete action. You can add new question using "Add New 

Question" 
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3. ADD/EDIT QUESTION 

    Admin can add new product questions by clicking “Add New Question” from the Manage 

Product Questions grid. To edit a question, click the "Edit" link for respective question in 

questions grid.  

 Details: Admin can add basic details of questions to shows on frontend. 

 Question: Product Question 

 Status: Select the status of question from "Pending", "Approved" and "Not 

Approved". If auto approve of question is set to "yes" then status of question is 

already set as "Approved" 

 User Type: Select the user type from "Guest","Registered Customer" and "Admin". 

 Nickname: Add the nickname of the questioner to show on the product questions 

tab. 

 Email: Add the email id of the questioner. When answer for the question email 

notification send to this email id. 

 Store View: Select the store view to show this question.
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 Assign Question to Product: Here you can assign questions to products. 

       

 

4. MANAGE PRODUCT ANSWERS 

    To manage product question's answers, go to Magento Admin > Market > Manage Product 

Answers. Here you find all product question's answer in grid. To Edit any answer detail, 

click the "Edit" link for respective answer. Admin can delete single or multiple answers 

using the delete action. You can add new answer using "Add New Answer" 
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5. SELECT THE QUESTION TO ADD ANSWER  

Admin user should select the question to add answer for it. 

     

6. ADD/EDIT ANSWER 

Admin user can Add/Edit answer for selected question. 

 Question: Question, this link will redirect to question edit page. 

 Answer: Enter the answer for question. 

 Status: Select the status of answer from "Pending", "Approved" and "Not 

Approved". If auto approve of answer is set to "yes" then status of answer is already 

set as "Approved" 

 User Type: Select the user type from "Guest", "Registered Customer" and "Admin". 

 Nickname: Enter the nickname to show along with product answers in the Product 

question tab. 

 Email: Enter the email Id. 

 Is Anonymous: Set to yes to show answer as anonymous in the frontend. 

 Is Certified: Set to yes to show answer as posted from a certified customer. 

 Likes: Shows the total count of likes. 

 Dislikes: Shows the total count of dislikes. 

 Abuses: Shows the total count of reports. 
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7. PRODUCT QUESTIONS ACTIVITY LOG 

    All user activities on p by users are listed in Marketing > Product Questions > Product 

Questions Activity Log. You can track user activities, when user like, dislike and report an 

answer as abusive. 
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8. PRODUCT QUESTIONS IN THE FRONTEND 

   To show the Product question tab in product view page first enable the extension and add 

product question tab. Default tab title is "Product Questions". Users can search product 

questions using the search box. Questions assigned to respective product with status 

"Approved" are shown here.  Users can ask new questions from the question form. User 

can Like, Dislike and Report Abuse the respective answer. 
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 By clicking "Read other answers" user can read all answers for respective 

question. 

      

 On click of "Give your answer" user can answer the question. 
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9. MY QUESTIONS AND ANSWERS IN CUSTOMER’S MY ACCOUNT SECTION 

Customers can check all product questions asked by him/her in the "My Question and 

Answers" tab in customer my account page. Where they can read answers to their product 

questions. 

 

10. HOW TO CONFIGURE FAQ PRO 

Go to [Magento 2 Admin] > Stores > Settings > Configuration > Sparsh Extensions > FAQ 

PRO 

 

Fill out values for below settings to make it work properly. 

 Enable FAQ: Choose Yes to enable this extension else choose No to disable it. On 

disabling it, FAQ block in frontend won’t be shown. 

 Do you want a category sidebar? : Choose “Yes” if you want to have a categories 

sidebar for FAQ block. 

 FAQ list label: Set the FAQ block title as per your requirement. This title will be 

displayed on the frontend. Title is optional to set. If you want to add FAQ on 

separate page, then leave title as blank. 
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11.   HOW TO ADD NEW FAQ CATEGORY 

Go to [Magento 2 Admin] > Login > Marketing > FAQ > Manage FAQ Category > Add 

New FAQ Category 

 

Fill the form details to add a new FAQ Category: 

 Category Name: Enter the name of FAQ category. 

 Description: Enter description of FAQ category. 

 Sort Order: Position / Order to display categories on frontend. E.g., 0, 1, 2 ... It will 

be displayed in ascending order. 

 Status: Status can be set as enabled or disabled according to requirements. 

 

 
 

12.   MANAGE FAQ CATEGORY DETAILS 

Go to [Magento 2 Admin] > Login > Marketing > FAQ > Manage FAQ Category 

  
You can find all FAQ categories added here. FAQ Category grid has details like Name, 

Status, Created Time, Modified Time and Sort Order. 

  
By Default, “General” category is added to the system which cannot be disabled / deleted. 

You can change category name according to your requirement and use it in frontend if 

needed. 

  
In order to edit FAQ, choose the “edit” option in select dropdown of action column. 
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You can also filter them with different attributes like Name, Status, Created Time, 

Modified Time, and Sort Order etc.… 

  
You can make multiple categories enable/disable/delete simultaneously by using the 

Action dropdown at top. 

     

13.    HOW TO ADD NEW FAQ 

Go to [Magento 2 Admin] > Login > Marketing > FAQ > Manage FAQ > Add New FAQ 

 

Fill the form details to add a new FAQ: 

 Enter Question: Enter FAQ question. 

 Manage FAQ Category: Choose FAQ Category from the dropdown. 

 Store View: Select store views for which FAQs will be shown. 

 Answer: Enter FAQ answer 

 Sort Order: Position / Order to display FAQs on front. E.g. 0, 1, 2 ... It will be 

displayed in ascending order. 

 Status: Status can be set as enabled or disabled according to requirements. 
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14.   MANAGE FAQ DETAILS 

Go to [Magento 2 Admin] > Login > Marketing > FAQ > Manage Faq. 
  
You can find all FAQs added here. FAQ grid has details like Question, Status, Store View, 

Category, Created Time, Modified Time and Sort Order. 

 

To edit FAQ, choose the “edit” option in select dropdown of action column. 

 

You can also filter them with different attributes like Category, Status, Store View, 

Question, Created Time, Modified Time, Sort Order etc… 

 

You can make multiple FAQs enable/disable/delete simultaneously by using the Action 

dropdown at top as shown in below screenshot. 
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15. HOW TO ADD FAQ BLOCK FOR GIVEN CMS PAGE 

Go to [Magento 2 Admin] > Login > Content > Elements > Pages > Add / Edit Page 

 

Open “Content” > Click on “Show / Hide Editor” button > Click on “Insert Widget” button 

 

Choose Widget Type as “FAQ PRO” > Click on “Insert Widget” button 

 
 

16. MIGRATE THE DATA FROM FAQ EXTENSION TO FAQ PRO EXTENSION 

We provide functionality that allows you to migrate from the FAQ Extension to the FAQ 

Pro Extension in one click. 

 

Users with FAQ Extension installed only see the Migrate button.   

 

Migrate Extension from Store > Configuration > Sparsh Extension > FAQ PRO 
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17.  STORE FRONT VIEW OF FAQ 

Clear cache from System > Tools > Cache Management if required 

Showing your FAQ like below on storefront when “Do you want category sidebar?” is 

chosen as “Yes”. 

 

Showing your FAQ like below on storefront when “Do you want category sidebar?” is 

chosen as “No”. 

 

 
 

 

 


